Entidad 3D :: Creación de juegos en 3D sin programar

Foro de Entidad 3D
 
PortalÍndiceBuscarMiembrosGrupos de UsuariosFAQChatAnalisisRegistrarseConectarse
. . . . . . . . . . . . . . . . . . . . . . . .
Visita el sitio oficial de Entidad 3D para descargar la última versión!
Si encuentras un bug en la útlima versión de Entidad 3D, comunícaselo directamente al autor de Entidad 3D, Jordi Perez via correo electronico. Si no estás seguro si es un bug o no, consúltalo con la gente del foro!
Si eres un usuario nuevo preséntate en el subforo de saludos y despedidas para asegurar tu cuenta! (Los usuarios que tengan 0 mensajes pasados los primeros 10 días de creada su cuenta serán eliminados como política de limpieza del foro)

Comparte | 
 

 Problema con OVERLAY

Ver el tema anterior Ver el tema siguiente Ir abajo 
AutorMensaje
RYKY000
Analista
Analista
avatar

Sexo : Masculino
Mensajes : 595
Edad : 25
Localización : Mexico

MensajeTema: Problema con OVERLAY   Lun Oct 29, 2012 8:58 pm

Pasa lo siguiente...

Dentro de el juego al accionar un comando con la sentencia del OVERLAY, este aparece por un microsegundo y enseguida desaparece.

Estoy corriendo el juego desde un .bat, ya para ser la distribucion, no entiendo que es lo que pasa...

Desde el gedit, me aparecía el mismo problema, y lo que hice fue mover las cordenadas de ubicación del OVERLAY, sin embargo, ahora me esta sucediendo lo mismo, y no entiendo porque, revise que no existieran "cruces" con lo comandos, pero al parecer todo esta correcto. lo aparezco con OVERLAY1 y lo desaparezco con OVERLAY0

Estoy muy estresado con esto, ya tengo un buen rato con este problema y ya no se me ocurre que hacer.

Que debo revisar??, que debo hacer??........

Gracias.
Volver arriba Ir abajo
Ver perfil de usuario
dariodados
Analista
Analista
avatar

Último Juego : Top Secret
Sexo : Masculino
Mensajes : 1012
Edad : 33
Localización : Buenos Aires Pergamino

MensajeTema: Re: Problema con OVERLAY   Lun Oct 29, 2012 9:18 pm

Revisa si por error no has modificado el valor cero que es el tiempo que dura el overlay:

ACCI OVERLAY1 1 0 0 0

ACCI OVERLAY1 (Numero de Imagen), (Tiempo) ( X ),( Y)

Volver arriba Ir abajo
Ver perfil de usuario http://da2analisis.hostzi.com/analisis.html
ev0lizard
Inquilino
Inquilino
avatar

Último Juego : Fury Road (fan free game)
Sexo : Masculino
Mensajes : 1950
Edad : 38
Localización : Pangea/Tierra

MensajeTema: Re: Problema con OVERLAY   Lun Oct 29, 2012 10:47 pm

no me hagas mucho caso, pero el verdadero problema creo que esta en que no puedes poner un overlay (o un pers) por menos de un segundo, necesitas que sea un segundo de duracion al menos (o eso entendi yo cuando trasteaba con esas cosas) no se si sera esto, si lo es, toca poner camara fija discretamente y montar el tema con un actor

mas cosas? no se, creo que ya lo habras mirado, lo evidente mira a ver la imagen, nombre y prefijo, que tenga ciertas proporciones, profundidad de color, etc.... ah por cierto, no recuerdo si en la version distribucion tambien, pero dentro del editor, el nombre del overlay tiene que tener el prefijo del primer nivel, es decir , con el que arrancaste el juego (se que lo arrancas con un bat, pero no se cuantos niveles tiene (si por ejemplo tienes un nivel para seleccion de personaje) ni en que nivel te pasa)
Volver arriba Ir abajo
Ver perfil de usuario
RYKY000
Analista
Analista
avatar

Sexo : Masculino
Mensajes : 595
Edad : 25
Localización : Mexico

MensajeTema: Re: Problema con OVERLAY   Lun Oct 29, 2012 11:12 pm

Gracias por las respuestas.

Lo del tiempo, no es, ya que a todos los tengo en cero y despues los desactivo con OVERLAY0.

Y la cosa, (para ser mas especifico), es que en el nivel existen 8 OVERLAY, y los 2 primeros funcionan sin problema, pero los 6 restantes son los que aparecen instantáneamente y despues se borran...

Que existan por menos de un segundo, si se puede, y de hecho es lo que me pasa, jejeje se aparecen y apenas se alcanza a distinguir la imagen y despues desaparece, pero en ese no hay problema si los dejas en 0 como menciona dario se quedan hasta que con otro comando los "borres".....

Si, todo eso ya lo revise ev0, y si tienes razon con lo del nombre del primer nivel, anteriormente me avia pasado y de eso aprendi, tengo.. un menu--salirdeljuego--1mapa. por lo cual los nombres de los OVERLAY los dejo con el nombre del 1mapa, aparte como les comento, tengo otros OVERLAY que funcionan bien, no se que pasa con estos......

jeje, ahora uno ya no me aparece....jajaja, me estoy volviendo loco....estoy seguro que va a ser una boberia....

Gracias
Volver arriba Ir abajo
Ver perfil de usuario
elPatrixF
Administrador
Administrador
avatar

Último Juego : ni dios sabe
Sexo : Masculino
Mensajes : 2868
Edad : 25
Localización : Ausente!

MensajeTema: Re: Problema con OVERLAY   Mar Oct 30, 2012 12:15 am

Asegúrate que no has repetido ningún número de Imagen, luego no se me ocurre mucho :\
Volver arriba Ir abajo
Ver perfil de usuario http://elpatrixf.com
Contenido patrocinado




MensajeTema: Re: Problema con OVERLAY   

Volver arriba Ir abajo
 

Problema con OVERLAY

Ver el tema anterior Ver el tema siguiente Volver arriba 
Página 1 de 1.

 Temas similares

-
» Problema desplazamiento pantalla
» Problema con el cursor
» Problema: no sé cómo acceder desde el AIRIS al resto de equipos de mi red doméstica
» Problema Fpse
» Problema no carga navegador

Permisos de este foro:No puedes responder a temas en este foro.
Entidad 3D :: Creación de juegos en 3D sin programar :: Entidad 3D :: Comandos-