Entidad 3D :: Creación de juegos en 3D sin programar

Foro de Entidad 3D
 
PortalÍndiceBuscarMiembrosGrupos de UsuariosFAQChatAnalisisRegistrarseConectarse
. . . . . . . . . . . . . . . . . . . . . . . .
Visita el sitio oficial de Entidad 3D para descargar la última versión!
Si encuentras un bug en la útlima versión de Entidad 3D, comunícaselo directamente al autor de Entidad 3D, Jordi Perez via correo electronico. Si no estás seguro si es un bug o no, consúltalo con la gente del foro!
Si eres un usuario nuevo preséntate en el subforo de saludos y despedidas para asegurar tu cuenta! (Los usuarios que tengan 0 mensajes pasados los primeros 10 días de creada su cuenta serán eliminados como política de limpieza del foro)

Comparte | 
 

 problema con texturas

Ver el tema anterior Ver el tema siguiente Ir abajo 
AutorMensaje
juantankeful
Amateur
Amateur
avatar

Último Juego : Illness - THE GAME
Sexo : Masculino
Mensajes : 126
Edad : 16
Localización : Lavalleja

MensajeTema: problema con texturas   Mar Feb 25, 2014 6:48 pm

No sabia si poner esto en modelación 3d o aquí, pero como es problema de la textura lo pongo aquí.
hice una espada en milkshape 3d con texturas de 256x256 pixeles y .bmp para que funcione con e3d, pero cuando la hice .bdy, y la cambié a .act, no funcionaba en actview me aparecía un cartel diciendome:"EngineBeginFrame failed" y le daba a aceptar pero seguia apareciendo, luego de un tiempo se cerró el actview, después pensé que seria problema de textura, lo hice sin textura y funciona pero no se que hacer, yo quiero ponerle la textura que tengo pero no me deja, si alguien sabe que pasa o a alguien le ha pasado y lo solucionó me dice, gracias

imagenes:

aqui esta la espada con la textura: [Tienes que estar registrado y conectado para ver esa imagen]

aqui se ve sin la textura en el actview:
[Tienes que estar registrado y conectado para ver esa imagen]

[Tienes que estar registrado y conectado para ver esa imagen]

las imagenes son pequeñas pero se entiende
Volver arriba Ir abajo
Ver perfil de usuario
Diablo
Amateur
Amateur
avatar

Sexo : Masculino
Mensajes : 184
Edad : 43

MensajeTema: Re: problema con texturas   Mar Feb 25, 2014 8:05 pm

Asegurate de que el .bdy lo exportas en una subcarpeta de entidad_3d (creala si es necesario , por ejemplo _modelos) , y que la textura que aplicas esta en dicha subcarpeta antes de aplicarla y  exportarlo.


[Tienes que estar registrado y conectado para ver este vínculo]

Aqui el link del video en formato .WMV:

[Tienes que estar registrado y conectado para ver este vínculo]

Saludos.


Última edición por Diablo el Mar Feb 25, 2014 8:40 pm, editado 2 veces
Volver arriba Ir abajo
Ver perfil de usuario
juantankeful
Amateur
Amateur
avatar

Último Juego : Illness - THE GAME
Sexo : Masculino
Mensajes : 126
Edad : 16
Localización : Lavalleja

MensajeTema: Re: problema con texturas   Mar Feb 25, 2014 8:25 pm

no me funciona, pero gracias por tu respuesta  Smile 
Volver arriba Ir abajo
Ver perfil de usuario
croviman
Moderador
Moderador
avatar

Último Juego : Aporía2
Sexo : Masculino
Mensajes : 1963
Edad : 37
Localización : Canelones

MensajeTema: Re: problema con texturas   Mar Feb 25, 2014 9:17 pm

Te movi el tema a modelacion, porque tiene que ver con un "problema" que estas teniendo con las herramientas de modelacion Smile

Te fijaste que la textura que quieres aplicar este en la misma carpeta que el bdy...? Seguro?

________________________________________
[Tienes que estar registrado y conectado para ver este vínculo]
Volver arriba Ir abajo
Ver perfil de usuario http://http.//atmosferismos.blogia.com
juantankeful
Amateur
Amateur
avatar

Último Juego : Illness - THE GAME
Sexo : Masculino
Mensajes : 126
Edad : 16
Localización : Lavalleja

MensajeTema: si   Mar Feb 25, 2014 9:48 pm

si, la espada tiene 4 partes: punta, filo, mango1, mango2, la punta y el filo tienen la misma textura, por lo tanto son 3, y puse las 3 en la carpeta armas, junto al bdy y al act
Volver arriba Ir abajo
Ver perfil de usuario
ev0lizard
Inquilino
Inquilino
avatar

Último Juego : Fury Road (fan free game)
Sexo : Masculino
Mensajes : 1950
Edad : 38
Localización : Pangea/Tierra

MensajeTema: Re: problema con texturas   Miér Feb 26, 2014 12:01 am

que lo has puesto en la carpeta armas? por que?

un poco de paciencia, leelo todo

esta el ms3d de la espada en la carpeta armas? o solo las texturas? o le has dicho que las texturas estan en la carpeta armas...? o has creado una carpeta que se llama armas y todo esta como dices en la carpeta creada incluyendo el ms3d? o el ms3d es un producto de nuestra imaginacion porque hacias el proceso completo sin grabar? o que usabas un ms3d con esqueleto de animacion de una hermosa bailarina de samba y no te acordaste de quitar el mot?

o no recuerdas que el compilador del milk para bdy solo funciona en su propia carpeta de archivos relevantes ajustados a tal operacion?

que el milk no funciona bien? a ver si es que el actview se te quedo pillado...

o que?

pues por todo lo que has dicho, salvo eso, desde aqui no veo razon para el fallo con respecto al milk, revisa todo bien, paso a paso, que esten en la misma carpeta y los materiales la misma ruta, que la espada vaya a ser un arma, no quiere decir que debas ponerla en la carpeta armas, quiza sea un despiste, eso pasa hasta en las mejores casas a veces...

con respecto a "EngineBeginFrame failed" es un error comun que escupe el actview si arrancas el preview del gedit y tienes el actview abierto, de hecho lleva un rato quitarlo sin el administrador de tareas (y eso dejando la tecla return o intro pulsada) lo deja inservible hasta que no lo reinicies

pero volvamos al asunto

no confundir la velocidad con el tocino, en e3d, dentro del nivel, no en el actview la espada sale ? me refiero poniendo el act como specificactor en un nivel nuevo sin na mas que la espada, el player y el cubo pa que no se asfixien

lo digo no vaya a ser que pusieras en marcha el actview antes de arrancar un nivel, eso hiciese que el actview se quedase pillado (en este supuesto? normal, lo he vivido varias veces) y ... eso explicaria varias cosas

AH otra cosa, recuerda en el milkshape unir todos los grupos que usen la misma textura con "Regroup" recuerdo de un modelo que tenia muchos grupos y me dio ese fallo, lo resolvi asi uniendo los de la misma textura, ya que tal proceso no afectara al texture mapping, vamos que no se descentra el dibujo sobre el modelo 3d
Volver arriba Ir abajo
Ver perfil de usuario
juantankeful
Amateur
Amateur
avatar

Último Juego : Illness - THE GAME
Sexo : Masculino
Mensajes : 126
Edad : 16
Localización : Lavalleja

MensajeTema: Re: problema con texturas   Miér Feb 26, 2014 12:57 am

lo puse en la carpeta armas, de entidad 3d, porque lo pienso usar como un arma, lo que hay en esa carpeta es el bdy, el act, las 3 texturas y el apj que queda despues de pasarlo a act. no, la espada no se ve en el juego, ya uni el filo con la punta y cambie los materials, y sigue sin funcionar, yo me rindo ok777  mejor busco alguna espada por ahi  changtg
Volver arriba Ir abajo
Ver perfil de usuario
ev0lizard
Inquilino
Inquilino
avatar

Último Juego : Fury Road (fan free game)
Sexo : Masculino
Mensajes : 1950
Edad : 38
Localización : Pangea/Tierra

MensajeTema: Re: problema con texturas   Miér Feb 26, 2014 10:16 am

no desistas, subela y le echamos un vistazo a ver
Volver arriba Ir abajo
Ver perfil de usuario
juantankeful
Amateur
Amateur
avatar

Último Juego : Illness - THE GAME
Sexo : Masculino
Mensajes : 126
Edad : 16
Localización : Lavalleja

MensajeTema: cual subo?   Miér Feb 26, 2014 6:03 pm

yo voy a subir la que tiene textura, en formato ms3d
te subo las texturas aparte
con textura:

texturas:

la espada:

la division entre mango (o como le digan) y el filo:

el mango:

no se porque la textura del filo se hizo .ink pero arreglalo con el paint, ya revise haber si era .ink pero no, es bmp, tambien las otras texturas
Volver arriba Ir abajo
Ver perfil de usuario
juantankeful
Amateur
Amateur
avatar

Último Juego : Illness - THE GAME
Sexo : Masculino
Mensajes : 126
Edad : 16
Localización : Lavalleja

MensajeTema: siii lo arreglué!!!!   Miér Feb 26, 2014 9:41 pm

siiii  waaasdf , el problema era que, las texturas las había hecho con paint, y en vez de ajustar a 256 pixeles, ¡Ajusté a 256 centimetros!! jajajajaa que noob, el paint ma habia trolleado mentirtl y ahora lo puedo ver en el act view mirenla mas de cerca:[Tienes que estar registrado y conectado para ver esa imagen]

hice otra que es la de kirito, jejeje, si quieren subo las dos, o solo una, la de kirito es esta:[Tienes que estar registrado y conectado para ver esa imagen]
casi ni se ve porque es un poco negra XD (no soy racista)
Volver arriba Ir abajo
Ver perfil de usuario
Contenido patrocinado




MensajeTema: Re: problema con texturas   

Volver arriba Ir abajo
 

problema con texturas

Ver el tema anterior Ver el tema siguiente Volver arriba 
Página 1 de 1.

 Temas similares

-
» Problema desplazamiento pantalla
» Problema con el cursor
» Problema: no sé cómo acceder desde el AIRIS al resto de equipos de mi red doméstica
» Problema Fpse
» Problema no carga navegador

Permisos de este foro:No puedes responder a temas en este foro.
Entidad 3D :: Creación de juegos en 3D sin programar :: Utilidades :: Modelación 3D-