Entidad 3D :: Creación de juegos en 3D sin programar

Foro de Entidad 3D
 
PortalÍndiceBuscarMiembrosGrupos de UsuariosFAQChatAnalisisRegistrarseConectarse
. . . . . . . . . . . . . . . . . . . . . . . .
Visita el sitio oficial de Entidad 3D para descargar la última versión!
Si encuentras un bug en la útlima versión de Entidad 3D, comunícaselo directamente al autor de Entidad 3D, Jordi Perez via correo electronico. Si no estás seguro si es un bug o no, consúltalo con la gente del foro!
Si eres un usuario nuevo preséntate en el subforo de saludos y despedidas para asegurar tu cuenta! (Los usuarios que tengan 0 mensajes pasados los primeros 10 días de creada su cuenta serán eliminados como política de limpieza del foro)

Comparte | 
 

 Problema con colisión con Bots

Ver el tema anterior Ver el tema siguiente Ir abajo 
AutorMensaje
croviman
Moderador
Moderador
avatar

Último Juego : Aporía2
Sexo : Masculino
Mensajes : 1963
Edad : 37
Localización : Canelones

MensajeTema: Problema con colisión con Bots   Miér Mar 19, 2014 1:52 pm

Pues resulta que estoy configurando unos bots para que se avalancen sobre el player sin disparar y que cuando lo toquen se ejecute un comando...
La cuestión es que los bots vienen, se avalanzan, tocan al player infinita cantidad de veces pero casi nunca activan el comando Sad
Que puede estar sucediendo....????

________________________________________
[Tienes que estar registrado y conectado para ver este vínculo]
Volver arriba Ir abajo
Ver perfil de usuario http://http.//atmosferismos.blogia.com
AlterEgo
Avanzado
Avanzado
avatar

Último Juego : SETA (completo)
Sexo : Masculino
Mensajes : 209
Edad : 35
Localización : Argentina

MensajeTema: Re: Problema con colisión con Bots   Miér Mar 19, 2014 3:08 pm

Toquetea los valores de la caja de colision, puede ser eso a mi me jodia con specificActor, quizas sea un bug tambien. Saludos!
Volver arriba Ir abajo
Ver perfil de usuario
croviman
Moderador
Moderador
avatar

Último Juego : Aporía2
Sexo : Masculino
Mensajes : 1963
Edad : 37
Localización : Canelones

MensajeTema: Re: Problema con colisión con Bots   Miér Mar 19, 2014 3:55 pm

Voy a probar...

Parece mentira que en "La Zona" hice enemigos similares sin ningún problema y ahora tengo todo configurado de forma correcta pero no funciona... Sad

Pruebo y te cuento...

________________________________________
[Tienes que estar registrado y conectado para ver este vínculo]
Volver arriba Ir abajo
Ver perfil de usuario http://http.//atmosferismos.blogia.com
croviman
Moderador
Moderador
avatar

Último Juego : Aporía2
Sexo : Masculino
Mensajes : 1963
Edad : 37
Localización : Canelones

MensajeTema: Re: Problema con colisión con Bots   Jue Mar 20, 2014 12:18 pm

Pues nada... He modificado las colisiones del player y nada... Sad
Eso si, descubrí que mi problema se debe a que la superficie por el que caminan los enemigos y el player es un "clip"... Si borro este "clip" se soluciona PERO no puedo hacerlo porque gran parte los escenarios de mi juego están compuestos por "act's" entonces lógicamente debo usar brushes "clip" para simular las colisiones con el piso... Sad

Alguna otra idea?!?!?

________________________________________
[Tienes que estar registrado y conectado para ver este vínculo]
Volver arriba Ir abajo
Ver perfil de usuario http://http.//atmosferismos.blogia.com
Diablo
Amateur
Amateur
avatar

Sexo : Masculino
Mensajes : 184
Edad : 43

MensajeTema: Re: Problema con colisión con Bots   Jue Mar 20, 2014 12:57 pm

Prueba poner un brush normal debajo del act de forma que no se vea , uno o dos texels por debajo.

Saludos.

En tal caso doy por hecho que los tienes en clip por encima del .act , una solucion seria bajarlos y cambiar sus propiedades a brush a todos de golpe si se puediera , a falta de modificar algun brush suelto , o en su defecto uno por uno , si no es que hay demasiados , o tal vez solo las zonas donde sea necesario para la interactuacion.


Última edición por Diablo el Jue Mar 20, 2014 2:55 pm, editado 2 veces
Volver arriba Ir abajo
Ver perfil de usuario
croviman
Moderador
Moderador
avatar

Último Juego : Aporía2
Sexo : Masculino
Mensajes : 1963
Edad : 37
Localización : Canelones

MensajeTema: Re: Problema con colisión con Bots   Jue Mar 20, 2014 1:31 pm

Gracias, es una buena idea, pero no la puedo aplicar ya que el actor que conforma el piso esta repleto de desniveles (algunos muy pronunciados) Seria una labor TITANICA conseguir poner solidos sin que se vean (no puedo hacerlos transparentes porque me da errores graficos con otros objetos transparentes que tengo por ahí...)

________________________________________
[Tienes que estar registrado y conectado para ver este vínculo]
Volver arriba Ir abajo
Ver perfil de usuario http://http.//atmosferismos.blogia.com
AlterEgo
Avanzado
Avanzado
avatar

Último Juego : SETA (completo)
Sexo : Masculino
Mensajes : 209
Edad : 35
Localización : Argentina

MensajeTema: Re: Problema con colisión con Bots   Jue Mar 20, 2014 3:06 pm

Como estan los joints de los esqueletos de los acts ? esqueletos extraños suelen provocar errores en las colisiones, mas en aquellos que son los que tocan el suelo.

Te iba a decir que pusieras brushes con textura transparente pero parece que te dan defectos graficos, y si haces el terreno irregular con el terrain generator ? por ahora no se me ocurre nada mas, si se me prende la lamparita aviso  Sad 
Volver arriba Ir abajo
Ver perfil de usuario
ev0lizard
Inquilino
Inquilino
avatar

Último Juego : Fury Road (fan free game)
Sexo : Masculino
Mensajes : 1950
Edad : 38
Localización : Pangea/Tierra

MensajeTema: Re: Problema con colisión con Bots   Jue Mar 20, 2014 3:14 pm

es muy raro, yo trabajo mucho con acts para los escenarios y clip, no recuerdo haber tenido ese problema, lo mas que se me ocurre es que hayas convertido los clips en un model y que quiza eso interfiera, aun asi, esto que menciono sucede muy rara vez, me decanto mas por el asunto del esqueleto del enemigo

aunque le veo mas fuerza a que incluso quiza con algo que haya en el ini a lanzar (un temporizador, alguna variable, parar al bot una vez que te haya tocado(para que no se repìta el arranque del ini) o que de un comportamiento no deseado porque se haya activado algo en otro enemigo que lleve el mismo ini)
Volver arriba Ir abajo
Ver perfil de usuario
Chukimax
Moderador
Moderador
avatar

Último Juego : Banguelo fight
Sexo : Masculino
Mensajes : 485
Edad : 25
Localización : Santiago,RM.

MensajeTema: Re: Problema con colisión con Bots   Vie Mar 21, 2014 2:06 am

Croviman, lo que yo hago es usar brush normales con transparencia completa tga.. es igual que usar clips en el caso de que cumplan la función de colisión  Razz 

________________________________________
[Tienes que estar registrado y conectado para ver esa imagen]
Volver arriba Ir abajo
Ver perfil de usuario http://www.chukimax.com
croviman
Moderador
Moderador
avatar

Último Juego : Aporía2
Sexo : Masculino
Mensajes : 1963
Edad : 37
Localización : Canelones

MensajeTema: Re: Problema con colisión con Bots   Vie Mar 21, 2014 10:18 am

Gracias por la ayuda muchachos!

Chuckimax - pregunto: acaso al usar transparencia completa TGA no voy a tener problemas con otras transparencias parciales TGA que tengo a la altura del piso???

Evo - voy a investigar en el tema... Smile

________________________________________
[Tienes que estar registrado y conectado para ver este vínculo]
Volver arriba Ir abajo
Ver perfil de usuario http://http.//atmosferismos.blogia.com
Contenido patrocinado




MensajeTema: Re: Problema con colisión con Bots   

Volver arriba Ir abajo
 

Problema con colisión con Bots

Ver el tema anterior Ver el tema siguiente Volver arriba 
Página 1 de 1.

 Temas similares

-
» Problema desplazamiento pantalla
» Problema con el cursor
» Problema: no sé cómo acceder desde el AIRIS al resto de equipos de mi red doméstica
» Problema Fpse
» Problema no carga navegador

Permisos de este foro:No puedes responder a temas en este foro.
Entidad 3D :: Creación de juegos en 3D sin programar :: Entidad 3D :: WorldEditor y Entidades-