Entidad 3D :: Creación de juegos en 3D sin programar

Foro de Entidad 3D
 
PortalÍndiceBuscarMiembrosGrupos de UsuariosFAQChatAnalisisRegistrarseConectarse
. . . . . . . . . . . . . . . . . . . . . . . .
Visita el sitio oficial de Entidad 3D para descargar la última versión!
Si encuentras un bug en la útlima versión de Entidad 3D, comunícaselo directamente al autor de Entidad 3D, Jordi Perez via correo electronico. Si no estás seguro si es un bug o no, consúltalo con la gente del foro!
Si eres un usuario nuevo preséntate en el subforo de saludos y despedidas para asegurar tu cuenta! (Los usuarios que tengan 0 mensajes pasados los primeros 10 días de creada su cuenta serán eliminados como política de limpieza del foro)

Comparte | 
 

 problema grabe con compliacion

Ver el tema anterior Ver el tema siguiente Ir abajo 
AutorMensaje
HomoViator
Principiante
Principiante
avatar

Último Juego : Anormal Crossing
Sexo : Masculino
Mensajes : 114
Edad : 23
Localización : Sevilla

MensajeTema: problema grabe con compliacion   Vie Abr 27, 2012 11:27 pm

Tengo un graaan problema: Resulta que de repente, a la hora de compliar mi nivel, me dice "Error compling level" y en la consola aparece le siguiente:

** BSP Compile Version: 15
** Build Date/Time: Jan 24 2006,18:29:11
--- Load Brush File ---
Entity 0, Brush 0: Bounds out of range
Num Solid Brushes : 324
Num Cut Brushes : 0
Num Hollow Cut Brushes : 0
Num Detail Brushes : 19
Num Total Brushes : 358
MakeBSPBrushes: Bad brush.
--- Remove Hidden Leafs ---
PlaceEntities: No valid entities for operation 36.
Failed to remove hidden leafs.
Compile Failed: GBSP_CreateBSP encountered an error, GBSPLib.Dll.

A que se debe????
Volver arriba Ir abajo
Ver perfil de usuario http://www.desahogoincomprensivo.blogspot.com
Invitado
Invitado



MensajeTema: Re: problema grabe con compliacion   Sáb Abr 28, 2012 12:53 am

En el manual entidad3d esta la respuesta donde dice preguntas frecuentes.
Volver arriba Ir abajo
HomoViator
Principiante
Principiante
avatar

Último Juego : Anormal Crossing
Sexo : Masculino
Mensajes : 114
Edad : 23
Localización : Sevilla

MensajeTema: Re: problema grabe con compliacion   Sáb Abr 28, 2012 7:28 am

lo he comprobado en el manual y resulta que ese error se debe a la ausencia de entidad DeathMatchStart pero resulta que la entidad esta puesta.
Cuando he intentado configurar la entidad, me he dado cuenta de que no me deja configurar ninguna entidad del mapa.
Pienso que tal vez tenga algo que ver con los errores que me da el programa World Editor Pro al principio, al abrir mi nivel , me aparece:

"Some Entities or Brushes did not load properly, see console for details.
To correct this problem, go to Proyect/Level Options and adjust your Headers path(s) if needed."

Pulso aceptar y me aparece este cuadro:

Spoiler:
 

Y entonces tengo que decirle al programa donde estan las texturas, los niveles y los actores. Tambien me pregunta por un tal archivo "Pawn.ini", pero no lo encuentro.
Una vez puestos todos los datos, pulso Aceptar y me sale el siguiente cuadro:

"Some Entities do not have corresponding type definitions. See console for details."

En la consola aparece lo siguiente:

Entity Configuracion1: type not found.
Entity Marcador1: type not found.
Entity AccionMenu1: type not found.
Entity Command1: type not found.
Entity ItemObject21: type not found.
Entity ItemObject22: type not found.
Entity ItemObject23: type not found.
Entity ItemObject24: type not found.
Entity ItemObject25: type not found.
Entity DeathMatchStart2: type not found.
Entity ItemObject26: type not found.
Entity ItemObject27: type not found.
Entity ItemObject28: type not found.
Entity ConfigArmaUno2: type not found.
Entity ConfigArmaCuatro1: type not found.
Entity Door2: type not found.
Entity SpecificActor3: type not found.
Entity ModelController1: type not found.
Entity ModelController2: type not found.
Entity MovingPlat1: type not found.
Entity Command2: type not found.
Entity ModelController3: type not found.
Entity Door3: type not found.
Entity Configuracion1: type not found.
Entity Marcador1: type not found.
Entity AccionMenu1: type not found.
Entity Command1: type not found.
Entity ItemObject21: type not found.
Entity ItemObject22: type not found.
Entity ItemObject23: type not found.
Entity ItemObject24: type not found.
Entity ItemObject25: type not found.
Entity DeathMatchStart2: type not found.
Entity ItemObject26: type not found.
Entity ItemObject27: type not found.
Entity ItemObject28: type not found.
Entity ConfigArmaUno2: type not found.
Entity ConfigArmaCuatro1: type not found.
Entity Door2: type not found.
Entity SpecificActor3: type not found.
Entity ModelController1: type not found.
Entity ModelController2: type not found.
Entity MovingPlat1: type not found.
Entity Command2: type not found.
Entity ModelController3: type not found.
Entity Door3: type not found.
Entity Configuracion1: type not found.
Entity Marcador1: type not found.
Entity AccionMenu1: type not found.
Entity Command1: type not found.
Entity ItemObject21: type not found.
Entity ItemObject22: type not found.
Entity ItemObject23: type not found.
Entity ItemObject24: type not found.
Entity ItemObject25: type not found.
Entity DeathMatchStart2: type not found.
Entity ItemObject26: type not found.
Entity ItemObject27: type not found.
Entity ItemObject28: type not found.
Entity ConfigArmaUno2: type not found.
Entity ConfigArmaCuatro1: type not found.
Entity Door2: type not found.
Entity SpecificActor3: type not found.
Entity ModelController1: type not found.
Entity ModelController2: type not found.
Entity MovingPlat1: type not found.
Entity Command2: type not found.
Entity ModelController3: type not found.
Entity Door3: type not found.
Test

Y luego carga el nivel, con tecturas y todo y me deja trabajar con el como soi nada pero cuando voy a compliar me da el error que anteriormente mencione.
¿Que esta ocurriendo?
Volver arriba Ir abajo
Ver perfil de usuario http://www.desahogoincomprensivo.blogspot.com
Invitado
Invitado



MensajeTema: Re: problema grabe con compliacion   Sáb Abr 28, 2012 2:30 pm

===============================================================
Que estas haciendo si entidad 3d debe estar por fuerza MAYOR en C: y no en E:
===============================================================

DICE la consola que no te funcionan ninguna de las entidades

COMO te van a funcionar si las tienes en el disco E:

CAMBIA de lugar a ENTIDAD3D donde dice el manual en disco C:.

como tan merme!

PD: APROVECHA de cambiar de EDITOR WEPRO a Gedit.
Volver arriba Ir abajo
HomoViator
Principiante
Principiante
avatar

Último Juego : Anormal Crossing
Sexo : Masculino
Mensajes : 114
Edad : 23
Localización : Sevilla

MensajeTema: Re: problema grabe con compliacion   Sáb Abr 28, 2012 5:09 pm

Lo he puesto en C y me da exactamente el mismo error... estoy desesperado Sad
Volver arriba Ir abajo
Ver perfil de usuario http://www.desahogoincomprensivo.blogspot.com
Invitado
Invitado



MensajeTema: Re: problema grabe con compliacion   Sáb Abr 28, 2012 5:16 pm

HomoViator escribió:
Lo he puesto en C y me da exactamente el mismo error... estoy desesperado Sad

NO funciona ninguna entidad.

Comensastes con el pie izquierdo con e3d.

Si quieres comienza nuevamente pero esta vez usa el editor de mapas GEDIT y asegurate que la ruta de entidad 3d sea en C:

Para comenzar es necesario que comiences bien con mucha lectura de los tutoriales.

PD: descargate nuevamente el programa y busca el archivo ini, puede que sea el problema, o concige que alguien te lo envie.

Pega esto y remplaza lo que tiene en WorldEPro.ini

Código:
[Grid]
Background=6710886
Color=12632256
SnapColor=13688896

[Paths]
TxlName=.\levels\texturas.txl
TxlSearchPath=.\levels
PreviewPath=.\Entidad3D.exe
Headers=.\src_entidad3d;.\src_entidad3d\game;.\src_entidad3d\fx
ObjectsDir=.\prefabs
ProjectDir=.\levels
Include=.\src_entidad3d;.\src_entidad3d\game;.\src_entidad3d\fx;.\src_entidad3d\levels
Actors=.\Actors
PawnIni=.\Pawn.ini

[DESKTOP-Summary]
Bars=10
ScreenCX=1280
ScreenCY=1024

[Tip]
StartUp=1
TimeStamp=Tue Jan 31 20:09:25 2006
FilePos=2595

[Settings]
PreviewPages=1

Y porfavor no usen mas ese editor..................................
Volver arriba Ir abajo
HomoViator
Principiante
Principiante
avatar

Último Juego : Anormal Crossing
Sexo : Masculino
Mensajes : 114
Edad : 23
Localización : Sevilla

MensajeTema: Re: problema grabe con compliacion   Sáb Abr 28, 2012 5:24 pm

Vale, problema resuelto jajajaja
Lo comento por si a alguien le ocurre lo mismo:
Resulta que le faltaban las rutas de los Headers, es decir, en el cuadro de "Level Options", en el apartado de "Headers Directories", tenia que poner la ruta de la carpeta FX, la carpeta "src_entidad3d" y la carpeta "game" (fx y game dentro de la otra).
Una vez lo indique fijandome en las direcciones de gedit complio sin problema.

Siento la comedura de cabeza pero muchas gracias!!
Volver arriba Ir abajo
Ver perfil de usuario http://www.desahogoincomprensivo.blogspot.com
 

problema grabe con compliacion

Ver el tema anterior Ver el tema siguiente Volver arriba 
Página 1 de 1.

 Temas similares

-
» Problema grabe
» Problema grabe con el photobucket en el foro, no se pueden visualizar las imágenes
» Tengo un problema grabe en mi foro ayúdenme plis!
» Problema desplazamiento pantalla
» Problema con el cursor

Permisos de este foro:No puedes responder a temas en este foro.
Entidad 3D :: Creación de juegos en 3D sin programar :: Entidad 3D :: WorldEditor y Entidades-